Do not upgrade your computer to an OS that is newer than your Avid Media Composer is qualified for.

Lower versions of OS X and Avid Media Composer still work great (and often better). Click on the links below.​

10.10.5

10.11.6

Application Manager

10.12.4

10 Pro

10.12.4

10.8.5

17.5

10.9.5

10.7.5

10.6.x